Квадратное уравнение

Квадратное уравнение задается в общем виде следующим образом:
AX2+BX+C=0
где: A,B и C - коэффициенты при неизвестном X.
Квадратное уравнение имеет корни (решение), если дискриминант уравнения больше или равен нулю. Если дискриминант уравнения меньше нуля, то уравнение не имеет решения.

См.
Дискриминант
Корни уравнения


Корни уравнения

Если дискриминант больше нуля, то квадратное уравнение имеет два различных корня, которые вычисляются по формулам:
X1=(-B+Sqrt(D))/2A
X2=(-B-Sqrt(D))/2A
где: Sqrt - функция Pascal, значением которой является квадратный корень аргумента.
Если дискриминант равен нулю, то квадратное уравнение имеет два одинаковых корня, которые вычисляются по формуле:
X=-B/2A

Замечание. A,B и C - коэффициенты квадратного уравнения.

См.
Квадратное уравнение


Дискриминант

Значение D, вычисляемое по формуле:
D=B2-4AC
называется дискриминантом квадратного уравнения.

См.
Квадратное уравнение